Jump to content

Please disable your Ad-Blocking software to continue using our website.

C.A.M.F.C - Members & Visitors area
Bravedan

FRSky Users in CAMFC please read.

Recommended Posts

 

MORE EU legislation coming next year, this will force 2.4GHz Radio manufacturers that allow firmware/software updates to TX and Rx to ensure their hardware being sold new can ONLY install and use firmware that is compliant IN THAT GEOGRAPHICAL AREA.

 

Obviously FRSky is one such likely affected. (but by no means the only)

 

Does not, it appears, affect existing sets sold before the due date directly (as was similarly the case with the now current firmware to comply with EU ruling on Listen Before Transmit), but will most likely introduce further incompatibility issues between old and new TX/Rx combos. Most likely to be affected seems to be the modules and Rx's that FRSky sold that do not have updated EU compliant firmware update options available from FRSky.

 

Basically, the EU IT doughnuts have belatedly realised that their prize LBT legislation had a massive black hole in it by just "pretending" you were located somewhere else.

 

Time to assess what's best for YOU.................

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


UK Web Hosting | PC Repairs Croydon | Cloud Hosting in London | UK Dedicated Servers | UK Reseller Hosting | UK Shared Hosting

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.